BioSPIP et BioSquelettes v. 4

Forum des Squelettes évolués pour SPIP : BioSPIP et ses BioSquelettes
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 [RESOLU] Message d'erreur clique sur lien articl

Aller en bas 
AuteurMessage
gonzamax



Nombre de messages : 2
Date d'inscription : 30/12/2005

MessageSujet: [RESOLU] Message d'erreur clique sur lien articl   Ven 30 Déc à 0:04

Bonjour, ou plutôt bonsoir

Warning: Cannot modify header information - headers already sent by (output started at /var/www/losgonza/inc-public.php3(53) : eval()'d code:3) in /var/www/losgonza/inc-public.php3(53) : eval()'d code on line 3

C'est le message d'erreur que j'obtiens quand je clique sur le lien d'un article. Est-ce que quelqu'un peut m'aider ?
J'ai installé la version 4 de biospip
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
Admin


Nombre de messages : 173
Date d'inscription : 17/12/2005

MessageSujet: Re: [RESOLU] Message d'erreur clique sur lien articl   Sam 31 Déc à 13:40

Vous devez avoir un problème avec les url-propres2 : supprimez le fichier /ecrire/mes_options.php3 ainsi que le fichier .htaccess et videz le cache de SPIP.

Bien cordialement,
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://biospip.frbb.net
gonzamax



Nombre de messages : 2
Date d'inscription : 30/12/2005

MessageSujet: Re: [RESOLU] Message d'erreur clique sur lien articl   Sam 31 Déc à 16:10

Merci beaucoup ça fonctionne
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
rezki



Nombre de messages : 11
Localisation : Paris
Date d'inscription : 05/01/2006

MessageSujet: URL propres   Ven 6 Jan à 0:11

J'ai aussi rencontré ce problème (erreur 500, après les manipulations conseillées sur le site), ça refonctionne désormais. Mais je me pose quand même la question. Pourrais-je quand même créer des pages à url prpres ? C'est cette fonction qui m'a fait adopter Biospip.
Par ailleurs, la suppression du fichier .htaccess aura-t-elle des conséquences sur le comportement du site ?
Je précise que je teste actuellement la bête sur Free, à l'url http://94700.free.fr/spip j'imagine que ceci explique cela.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.rezki.net
Admin
Admin


Nombre de messages : 173
Date d'inscription : 17/12/2005

MessageSujet: Re: [RESOLU] Message d'erreur clique sur lien articl   Ven 6 Jan à 9:50

Oui, le problème vient de Free qui n'est pas très permissif (ce qui leur permet d'ailleurs de proposer des hébergements gratuits à la pelle).

Je conseille à tout le monde d'essayer les sites SPIP en intra sur un serveur Apache. Sous Linux ça fonctionne à merveille via un LAMP, toutes les distributions peuvent l'installer. Sous Windows c'est un peu plus merdique, il faut installer Easy PHP ou Wamp, mais des fois on a l'impression de revenir à du 56K tellement le traitement des pages peut être lent. Sous Linux on est forcément plus rapide qu'en ADSL et c'est normal car on est en local, c'est de l'immédiat.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://biospip.frbb.net
David Haillant



Nombre de messages : 8
Date d'inscription : 10/01/2006

MessageSujet: Re: [RESOLU] Message d'erreur clique sur lien articl   Mer 25 Jan à 10:48

Bonjour,

J'ai le même message d'erreur :
Citation :
Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/biospip/inc-public.php3(53) : eval()'d code:3) in /var/www/html/biospip/inc-public.php3(53) : eval()'d code on line 3

J'ai évidemment essayé ces manips :
Citation :
supprimez le fichier /ecrire/mes_options.php3 ainsi que le fichier .htaccess et videz le cache de SPIP.

... mais je n'ai ni "/ecrire/mes_options.php3" (uniquement "/ecrire/mes_options_biospip.php3", supprimé et ça n'a rien modifié), ni de .htaccess.
Quant au cache, il a été vidé plusieurs fois sans succés.
Et aussi, les urls "propres" n'ont jamais fonctionné pour le moment. On les active comment ?

L'erreur n'apparait pas lorsque je suis connecté en tant que "admin"... et uniquement sur l'album Walma apparemment ?

Dans des commentaires sur spip-contrib, j'ai vu qu'il était question de cookies.

Une idée ?

Merci beaucoup !
David.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Admin
Admin


Nombre de messages : 173
Date d'inscription : 17/12/2005

MessageSujet: Re: [RESOLU] Message d'erreur clique sur lien articl   Mer 25 Jan à 19:01

Bonjour,

pour les URL propres il vous faut aller lire la documentation sur www.spip.net/fr et sur www.spip-contrib.net car ce n'est pas dépendant de BioSPIP mais uniquement de SPIP (fonctionnalité interne à SPIP).

Pour ce qui est de l'album Walma, vous devez avoir soit un problème avec votre hébergeur, soit un problème avec votre navigateur (qui n'accepte pas les cookies par exemple).

Mais pour l'album Walma je vous renvoie vers le site de walma (voir les crédits du site pour avoir l'adresse exacte de Walma.

bien cordialement
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://biospip.frbb.net
Contenu sponsorisé




MessageSujet: Re: [RESOLU] Message d'erreur clique sur lien articl   

Revenir en haut Aller en bas
 
[RESOLU] Message d'erreur clique sur lien articl
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» J'ai un message d'erreur en anglais quand je veux ouvrir mon livre ou le modifier.
» Bug chargement HEREDIS 11 pro
» [Résolu] Image? Message d'erreur... :s
» Message d'erreur amusant !
» Message d'erreur : Argument hors limites

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
BioSPIP et BioSquelettes v. 4 :: Installation-
Sauter vers: